Jump to content

Neighbors 95


Recommended Posts

Hello all, my neighbor has a 95 4x4 auto that recently developed a problem where the speedo, tach, overdrive and cruise control stopped. He changed the abs sensor with no changes. Fuses are all in tact. The alternator is only putting out 12.3. Could it be a low voltage issue? He is going to check ground connections and wiring tomorrow. Any advice is appreciated. Thanks

 

Sent from my SM-G781U using Tapatalk

 

 

Link to comment
Share on other sites

2 hours ago, operator mike 82 said:

Not sure, and forgive my ignorance, but what are the clock springs?

Sent from my SM-G781U using Tapatalk
 

It’s under the steering wheel it’s what let’s power through the controls on steering wheel when turning if that makes sense 

Link to comment
Share on other sites

Strange that all that happened at once. Like Mark said, there’s common issues associated with each one individually but all together is strange. I wonder if there’s a common ground, maybe at the dash end that could have all this associated with it? A guy would have to dig through a wiring diagram to see if there’s something tying it all together. 

Link to comment
Share on other sites

pcm power or ground issue, no ecm on this engine
I didn't think so but I wasn't sure so I covered my bases.

Sent from my SM-G986U using Tapatalk

  • Like 1
Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...