Jump to content
Water_Lover

What are normal Temps on 99 F-350

Recommended Posts

My neighbor has a early 99 F-350 and we put a 4" turbo back exhaust S & B intake and a Edge Evolution on it he is seeing Egts of 1000 at 70 mph and oil temps of 200 is this normal for the Powerstroke

Share this post


Link to post
Share on other sites

Is that with the edge turned up?

 

A friend of mine who has a 96 Powerstroke with a superchips tuner will see 1,000-1,100* post turbo all day long towing heavy. As he puts it, he has 8 cylinders creating the heat, not 6 like WE do.

Share this post


Link to post
Share on other sites

It is pre turbo it is in the exhaust manifold and truck is empty going up a fair grade at 70 with the 100 hp tune. the oil temp seems kinda high the alarm was going of at 200 that is the default setting on the edge.

Share this post


Link to post
Share on other sites
It is pre turbo it is in the exhaust manifold and truck is empty going up a fair grade at 70 with the 100 hp tune. the oil temp seems kinda high the alarm was going of at 200 that is the default setting on the edge.

 

 

Probably isn't too bad then

 

70 up a grade empty is hard for a ford to do

Share this post


Link to post
Share on other sites

I wouldnt be worried since his probe is pre turbo... I assume it is an auto? Ask him if he can take a look at his live data stream to monitor his tranny temp.

Edited by 95dieselsmoke

Share this post


Link to post
Share on other sites

QUOTE (Water_Lover @ Jun 7 2009, 09:24 PM)

70 up a grade empty is hard for a ford to do

 

:blah::blah: hmmm well I backed out of it when the needle crept past 1200 going up Snoqualmie pass. But I WAS doin 95mph on 38's.

 

Have never heard of any problems with high oil temps, but anything is possible. If he's working it hard up a grade 1000* isnt unusual...... especially if hes in OD. Kick it out of OD, raise the RPMs and that should of course drop his EGTs a bit.

 

Not fan of Edge products at all.....

Share this post


Link to post
Share on other sites

:blah::blah: hmmm well I backed out of it when the needle crept past 1200 going up Snoqualmie pass.

wuss

Not fan of Edge products at all.....

agreed

Share this post


Link to post
Share on other sites

Your truck running yet Jeffy? NO???? Ahhh well thats a bummer. :lol:

Like I've said before, some of us aren't satisfied with 300 hp :P . My truck wasn't broke when I took it off the road. :mn:

Share this post


Link to post
Share on other sites

My truck wasn't broke when I took it off the road. :mn:

 

What about you complaining about bad brakes, shocks and front end problems? Fix those problems yet? :p:

Share this post


Link to post
Share on other sites

What about you complaining about bad brakes, shocks and front end problems? Fix those problems yet? :p:

brakes were worn, shocks were new. And I wanted to rebuild the front end just because :mn:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×